Chevy Bolt EV Forum banner
  • Hey Guest, welcome to We encourage you to register to engage in conversations about your Bolt.
1 - 2 of 2 Posts

· Registered
33 Posts
Discussion Starter · #1 ·
I had a Duosida adjustable 32 amp max EVSE stop working after a month and a half of use. I thought it might have been water getting into it, but the vendor took it apart and says no, it's dry.

It worked fine on my 2020 Bolt for a while. Then it suddenly started trying and failing. No fault light on the Duosida EVSE box, just the charging LED coming on and going off. The dashboard light would go from orange to green for a moment and then go back to orange. The display behind the steering wheel would say "Unable to charge". There was an indicator in the corner of the LCD display that said "100", indicating that the battery was fully charged, which it wasn't.

The OEM Chevy EVSE worked fine at 120V and 240V. Another brand of 32 amp EVSE worked fine.

The vendor charged up his Kia Soul fully and successfully with my charger. He compared the 100% charge setting with another 32A Duosida and they were the same.


Any ideas welcome.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.