Chevy Bolt EV Forum banner

41 - 60 of 65 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #41
It sounds like the feature is only activated on certain models. I remember seeing a document of approved phones once upon a time. Maybe they moved that into code?
 

·
Registered
Joined
·
180 Posts
It sounds like the feature is only activated on certain models. I remember seeing a document of approved phones once upon a time. Maybe they moved that into code?
If so, that shows an epic level of software incompetence on GM's part to not even support Google's official reference devices.
 

·
Registered
Joined
·
58 Posts
It sounds like the feature is only activated on certain models. I remember seeing a document of approved phones once upon a time. Maybe they moved that into code?
My phone (Galaxy S7) is on the list of supported devices, but I've had no luck getting keypass working this go around.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #45
My phone (Galaxy S7) is on the list of supported devices, but I've had no luck getting keypass working this go around.
Does the app give you the option to set it up? It sounds like it's completely disabled for some.
 

·
Registered
Joined
·
203 Posts

·
Registered
Joined
·
180 Posts
LOL at "iPone"!

They didn't even bother to proofread the document. Also, supporting only some of the buggiest and most inconsistent Android devices on the market, seriously???

Samsung is kind of notorious for doing weird things that break compatibility, which is why I've avoided their devices like the plague ever since the Galaxy S2 Superbrick fiasco.
 

·
Registered
Joined
·
78 Posts
It seems to hang on this pairing screen for 5 minutes or so, then says we can't setup keypass.
Mine did that too the first time. I went into Bluetooth settings and removed the device on my phone, started over, and it worked the second time.
 

·
Registered
Joined
·
51 Posts
Ok, I don't get that step, it seems it does not detect my car, question, when you open bluetooth properties, and select the settings on the MyChevrolet use for what does it show?

Thanks,
Freddy
Today after a day of not testing, tried and the phone showed pairing for a brief moment and then the error of not finding the car appeared again.

I then:
1 - Removed the OBD2 reader just in case
2 - Manually set the permission so the camera was allowed to be used by the app
3 - Reset the phone and the console

Started the process again, this time after the pairing message, the console showed the QR code, but the phone was stuck on pairing, after I decided to cancel the camera scan screen appeared and the QR too, the phone scanned the QR and is now working, there is something iffy there

My phone is a Galaxy S10 with Android 10.

On the phone bluetooth settings I now show the keypass device and MyChevrolet.


Keypass Bluetooth 20200328_111503.jpg
 

·
Registered
Joined
·
203 Posts
It seems to hang on this pairing screen for 5 minutes or so, then says we can't setup keypass.
Ditto. Just got 3.27. There's KeyPass back. Ran out and tried it. Same result. D1ck diddly. Same thing as you. Never a QR code. The phone however seems to think it has paired with KeyPass but not the infotainment.
The phone will gladly pair as a phone. It will connect to the wifi. Just not KeyPass. I didn't bother to try Android Auto. It worked before no problem though.
Samsung Galaxy S7 running stock unmolested Android 8.
 

·
Registered
Joined
·
197 Posts
I finally had gotten version 3.27.0. The set up was quite uneventful. Couldn't finish the first time I tried inside an indoor garage though. I think it'd be better to have clear sky overhead as it may need to go through OnStar, which is satellite based.

-TL

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
197 Posts
You are right. I heard story that an overturned truck couldn't get to OnStar because the satellite antenna on the cab roof wasn't pointing skyward. Maybe it was in the early days when cellular infrastructure wasn't adequate in the remote area. Shouldn't be my case in the city. I stand corrected.

-TL

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
4,542 Posts
You are right. I heard story that an overturned truck couldn't get to OnStar because the satellite antenna on the cab roof wasn't pointing skyward.
The myth that OnStar is satellite based is a strong one, as evidenced by your use of the phrase "satellite antenna". Even my dealer tried to tell me that I didn't have to worry about cellular coverage with OnStar, but he was either mistaken or just plain flat out lying.
 

·
Registered
Joined
·
2 Posts
Not sure if this thread is still considered active, but I just got a used 2017 and have been trying to setup KeyPass. I used the factory reset settings to clear personal data in the car, and went through the KeyPass Setup from the MyChevrolet app. I get a prompt on the car screen saying to start the car and press Continue, after a few seconds, the phone app "Pairing with Vehicle" I get the Pair and Connect request from Android (10.0, OnePlus 6T) and do the connect, then the car shows the QR code. This is where I'm stuck. The phone tells me I'll need to pair with the QR code, but never hides the overlaid pairing message. I can't dismiss it, back button doesn't clear it, it just sits there. Finally I kill the app. Any ideas? I should also mention, I'm paired for music and calls, and I can do Android Auto on the screen over USB. This is the only integration that doesn't work.

29241
 

·
Registered
Joined
·
3,310 Posts
Any ideas?
checkout this post from @Sibilance
 

·
Registered
Joined
·
4 Posts
I have a 2018 Bolt EV and had used KeyPass for about a year without issues on a Galaxy S5. Then it went away in a My Chevrolet update. So annoying.
Now I have a Xiaomi-Mi A3 phone running Android One (9). I have tried for hours and periodically I can get as far as @atk above and get a QR code on the console and the scan screen but that modal dual "Pairing with Vehicle" covers my ability to complete the registration. So very frustrating.
I have done the factory reset of saved preferences on the car and changed the Bluetooth AVRCP version to 1.6 and still it's like 1 in 20 attempts to get as far as you see below. Seems like timing problems with the software.
I am just hoping for another My Chevrolet update. Or someone to discover a trick.
p.s. people ask why do you need keep house if you have the cellular O-Star connection. There are 3 reasons.
1. If you are in an area like a national park with no cellular access.
2. If you are past the 5 years free basic On-Star membership.
3. It's a lot faster to perform actions.
29269
29270
 

·
Registered
Joined
·
6 Posts
I have a 2018 Bolt EV and had used KeyPass for about a year without issues on a Galaxy S5. Then it went away in a My Chevrolet update. So annoying.
Now I have a Xiaomi-Mi A3 phone running Android One (9). I have tried for hours and periodically I can get as far as @atk above and get a QR code on the console and the scan screen but that modal dual "Pairing with Vehicle" covers my ability to complete the registration. So very frustrating.
I have done the factory reset of saved preferences on the car and changed the Bluetooth AVRCP version to 1.6 and still it's like 1 in 20 attempts to get as far as you see below. Seems like timing problems with the software.
I am just hoping for another My Chevrolet update. Or someone to discover a trick.
p.s. people ask why do you need keep house if you have the cellular O-Star connection. There are 3 reasons.
1. If you are in an area like a national park with no cellular access.
2. If you are past the 5 years free basic On-Star membership.
3. It's a lot faster to perform actions.
View attachment 29269 View attachment 29270
Hey, this worked for me after being stuck at this same spot as you.
 
41 - 60 of 65 Posts
Top