Chevy Bolt EV Forum banner
  • Hey Guest, welcome to We encourage you to register to engage in conversations about your Bolt.

MyChevy App upgrades

12159 Views 54 Replies 17 Participants Last post by  M1A4ME
This article might interest you.
Energy Assist feature has improved tremendously and more improvements to come.
GM enhances app for Chevy Bolt
Electronics Automotive navigation system Gps navigation device Electronic device Technology
See less See more
1 - 15 of 55 Posts
Just got version 5.01 in IOS today. Ugly dark mode, things have been moved around, and tire pressure is gone, but it seems to work. Had to set up KeyPass [again]. Let's see if this update fixes the loss of setup that's been going on for a few months now.
There is a Tire Pressure section under "Vehicle Status" but right not it seems not to be filled in. Not "odometer" either.
I don't have a 'vehicle status' section. I do have the new "dark mode" MyChevy app ver 5.01. I do have odometer current and life, along with efficiency.
Sky Font Screenshot Technology Circle
See less See more
Look to the top right of the picture you took right above the red triangle. You have to scroll over a bit to click on it.
Thx. That brings up "recommended Services" - the battery recall and tire rotation. If I click on "Done" then I get the old style display with tire pressure [I didn't get that far last time]. Even when I uncheck those service items, it still insists that I click thru them to get to the tire pressure. Oh well...
Yes. Very irritating! Are you actually getting a tire pressure and not just "updating"?
I have 4 #s there that seem reasonable.
I hate dark mode. Imagine reading a book or newspaper where the page is black and the text is white. Just because you can do it doesn't mean you should...
  • Like
Reactions: 1
For mobile applications, I find it easier to use dark mode to reduce the glare that I get from white backgrounds. Especially in the middle of the night / early morning when the ambient environment is similarly dark.
Good point...
Keypass is now useless for me. MyChevy app 5.0.1 (8). Every since the release of 5.0 it won't keep keypass setup. Tried about a dozen times. It's the app, not the car; the keypass settings on the car say it's set up for my iPhoneXR even when Keypass says "Run Setup". If I delete my phone from the car's keypass device list, Keypass setup always works [setup needs internet connectivity working for the app]. It stays connected for maybe a day, then back to 'run setup'. If GM is trying to kill Keypass so they can sell OnStar, why not just remove it from the app? I find it useful [2017LT]. A year from now my free 'basic' "connected services" package goes away, and w/out Keypass I have no connection to the car. I'm certainly not going to pay $15/month for OnStar.

Has anyone got Keypass to stay setup with 5.0.x?
See less See more
I should have noted I did remove and re-install the app, reboot the phone, reboot the infotainment system. Still no Keepass joy. I can't see how anything GM can do to the car remotely would change anything. The car didn't change [unless GM is now doing OTA updates], the app did. Infotainment SW ver still says 14.5.0.
When you are paired, you get a little icon at the top beside the name of the car, and when you are actually close enough to connect it is colored (green?).
This is great info. I've been puzzling re: how to know keypass status w/ ver 5 of the app. Yes, it's green when connected.
The iOS app just got an update, to 5.2.0(254). It might have fixed the keypass repeated setup problem (I removed and reinstalled the app). So far, so good. If it's still working in a few days, it's fixed. Now if I could only get it to stop asking me to log in while I'm driving - since ver 5, when I start the app on CarPlay, it tells me to stop driving and log in, even tho 'stay logged into the app' is active. I have cellular data turned off for it, since it can be a data hog and I have a very limited data plan. That could be part of my problem.
Please let us know. It did not help my keypass problem, but I did not totally delete and re-install either. I'll try that.

Also, what do you do with the app in CarPlay? Do you actually get some useful routing and charging info? It has never worked for me!
Keypass is still alive this morning, and that's a first with ver 5 of the app -- a good sign. The app did log me out overnight though, so that problem is still there.
I use it mostly for keeping a remote eye on the battery SOC. I don't have a paid OnStar account, so no routing [nav], and I'd never trust the app for finding a [working] charging station when I really needed one - like on a long trip.
To clarify -- when I say the app wants me to log in, that's before it starts the app where I enter email and password, and is different from the PIN needed to connect to the car [that uses face ID, and seems to work ok].

I should also note that when pairing keypass with the car, I've needed to delete the existing entery for my phone under keypass setup before running setup; else it fails. The app forgets about the keypass pairing, but the car does not.
Well... the app just lost Keypass setup. So no, it's not fixed.
7 months later... after updating the app to 5.8.0 (715) [the Dec 14 release], keypass has not needed to be setup after more than a week of use [2017LT, iPhoneXR, iOS 15.2]. It's been almost a year since this issue started. This is encouraging since my 5 y of free OnStar connectivity goes away in June and keypass becomes my only remote connection to the car. The app is still a piggy bucket of bugs, but this is progress. Anyone else seeing similar results w/ this update?
The app never worked in our garage, and only worked half the time when on the road. Tried uninstalling, and reinstalling over the years. After several forced stops some weeks ago, it has worked perfectly. Only took a bit over 4 years, but they seem to have it working now.
So perhaps a miracle has occurred... Good to get a 2nd opinion that at least that part of the app is working better.
1 - 15 of 55 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.